All API endpoints are operational now and are working fine. We will asses today’s outage and take necessary actions to improve the API uptime further.
Posted May 06, 2022 - 08:42 MDT
Monitoring
We are monitoring relevant incidents and we haven't seen performance degradation in recent time. We will continue to monitor and update this incident with relevant details.
Posted May 06, 2022 - 07:54 MDT
Identified
There are sporadic timeouts and high latency observed on search APIs, we have identified the issue and are waiting on fix for it. API's underlying infrastructure is facing an issue on GCP vis-à-vis Apigee - https://status.cloud.google.com/incidents/4Qvmd4q81VnA9RirCMqV & https://status.apigee.com/, we are monitoring and awaiting the resolution of it. Meanwhile API users might experience sporadic high latency or timeouts
Posted May 06, 2022 - 06:31 MDT
This incident affected: Cars (Search - Inventory Search, Search - Inventory Search API - Facets, Search - Inventory Search API - Stats, Search - Dealers Active Inventory, Search - Recent Inventory Search, VIN History API, Dealer API, VIN Decoder - Basic Decoder - VIN Decoding, Market API - Market Days Supply (MDS), Market API - Sales Stats API).