API Service Outage — SSL Certificate Expiry

Incident Report for Marketcheck Cars Inc

Resolved

Incident Name: API Service Outage — SSL Certificate Expiry
Impact: Major Outage
Affected Component: API Service
Status: Resolved
Started: April 6, 2026 · 12:00 AM UTC
Resolved: April 6, 2026 · 2:43 AM UTC
Duration: 2 hours 43 minutes
Message: An expired SSL certificate caused failed secure connections to the API service between 12:00 AM and 2:43 AM UTC. The certificate was renewed and redeployed, restoring normal operations. We are implementing improved certificate monitoring and automated renewal alerts to prevent recurrence.
Posted Apr 05, 2026 - 18:00 MDT