Resolved
The Marketcheck API has remained fully operational and stable since 11:56 UTC, with no further errors observed. We are marking this incident as resolved. While our upstream cloud infrastructure provider's incident may remain open, it is no longer affecting our service. All systems are back to normal, and no action is required on your side.
Posted Jun 29, 2026 - 09:52 MDT
Monitoring
The Marketcheck API experienced a brief disruption between 11:49 and 11:56 UTC (17:19–17:26 IST) on 29 June 2026, during which some requests may have failed or timed out. The cause was an ongoing incident with our upstream cloud infrastructure provider.
The API has since recovered and is currently operational. We are continuing to monitor closely and will share further updates if anything changes.
Posted Jun 29, 2026 - 06:29 MDT
This incident affected: Cars (Search - Inventory Search, Search - Inventory Search API - Facets, Search - Inventory Search API - Stats, Search - Dealers Active Inventory, Search - Private Party Search, Search - Auction Search, Search - Recent Inventory Search, Search - Listing Details, Search - Auto Complete, Dealership Syndication API, Cached Images API, VIN History API, Dealer API, Dealership API, VIN Decoder - Basic Decoder - VIN Decoding, VIN Decoder - Basic Decoder - Taxonomy Auto Complete, VIN Decoder - Basic Decoder - Taxonomy Facets, VIN Decoder - Enhanced VIN Decoder, VIN Decoder - NeoVIN Decoder, VIN Decoder - Available Options Packages, Market API - Market Days Supply (MDS), Market API - Sales Stats API, Market API - Popular cars API, Market API - Car Price Prediction API, Market API - Marketcheck Price API, MarketMatch - Rank Dealers for a Vehicle, MarketMatch - Rank Vehicles for a Dealer, OEM Incentives API - Incentive Search API, OEM Incentives API - Incentive by make and zip API, CRM Cleanse API, VINData API - Generate AAMVA VINData Report, VINData API - Access AAMVA VINData Report, CarsXE API), Cars UK (UK Inventory API - Inventory Search, UK Inventory API - Inventory Search Auto Complete, UK Inventory API - Listing Details, UK Inventory API - Recent Inventory Search, UK VRM History API, UK Dealer APIs, UK Dealership API, UK Car Price Prediction API, UK Marketcheck Price API), Heavy Equipments (Inventory Search API, Inventory Search API - Auto Complete, Inventory Search API - Listing Details, Dealer API), Recreational Vehicles (RV) (Inventory Search API, Inventory Search API - Auto Complete, Inventory Search API - Listing Details, Dealer API), Motorcycles (Inventory Search API, Inventory Search API - Auto Complete, Inventory Search API - Listing Details, Dealer API), and Recreational Vehicles (RV) UK (Inventory Search API, Inventory Search API - Listing Details, Dealer API).