DNS resolution failures
Incident Report for Marketcheck Cars Inc
Resolved
The issue has been resolved, and all API endpoints are fully operational. We will assess today's outage and work towards improving uptime moving forward.
Posted Oct 14, 2024 - 06:24 MDT
Monitoring
The DNS resolution issues have been resolved. The intermittent failures we experienced were primarily due to extended DNS propagation times. With the issue now resolved, services are returning to stability. We will keep monitoring the situation to ensure optimal performance & review the recent outage and take corrective actions so that it does not happen again.
Posted Oct 14, 2024 - 05:03 MDT
Identified
We have observed intermittent failures for dns resolution. We have identified the issue and working on the fix.
Posted Oct 14, 2024 - 03:48 MDT
This incident affected: Cars (Search - Inventory Search, Search - Inventory Search API - Facets, Search - Inventory Search API - Stats, Search - Dealers Active Inventory, Search - Private Party Search, Search - Auction Search, Search - Recent Inventory Search, Search - Listing Details, Search - Auto Complete, Cached Images API, VIN History API, Dealer API, VIN Decoder - Basic Decoder - VIN Decoding, VIN Decoder - Basic Decoder - Taxonomy Auto Complete, VIN Decoder - Basic Decoder - Taxonomy Facets, VIN Decoder - Enhanced VIN Decoder, VIN Decoder - NeoVIN Decoder, Market API - Market Days Supply (MDS), Market API - Sales Stats API, Market API - Popular cars API, Market API - Stats API [DEPRECATED], Market API - Car Price Prediction API, Market API - Marketcheck Price API, OEM Incentives API - Incentive Search API, CRM Cleanse API), Cars UK (UK Inventory API - Inventory Search, UK Inventory API - Listing Details, UK Inventory API - Recent Inventory Search, UK VRM History API, UK Dealer APIs, UK Car Price Prediction API), Heavy Equipments (Inventory Search API, Inventory Search API - Auto Complete, Inventory Search API - Listing Details, Dealer API), Recreational Vehicles (RV) (Inventory Search API, Inventory Search API - Auto Complete, Inventory Search API - Listing Details, Dealer API), Motorcycles (Inventory Search API, Inventory Search API - Auto Complete, Inventory Search API - Listing Details, Dealer API), and Recreational Vehicles (RV) UK (Inventory Search API, Inventory Search API - Listing Details).