The issue has been fixed and all APIs are fully operational now and we will further investigate this incident with Apigee and take measures to improve API uptime in the future
Posted Nov 11, 2020 - 08:31 MST
Monitoring
A fix has been deployed and error rate has declined significantly. We are monitoring the API as fix propagates through entire system.
Posted Nov 11, 2020 - 08:02 MST
Update
We are continuing to work on a fix for this issue with Apigee
Posted Nov 11, 2020 - 06:40 MST
Identified
There is an issue with our API management system Apigee. We've reached out to their support and we are currently trying to mitigate it
Posted Nov 11, 2020 - 05:20 MST
Investigating
We are observing high latency and some times complete failure on few API calls. On retry these calls are working. We are investigating this issue
Posted Nov 11, 2020 - 04:50 MST
This incident affected: Cars (Search - Inventory Search, Search - Inventory Search API - Facets, Search - Inventory Search API - Stats, VIN History API, Dealer API, VIN Decoder - Basic Decoder - VIN Decoding, Market API - Market Days Supply (MDS)).